const regex = /(?m)^[AB][ ]([0-9]{3})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[AB][ ]([0-9]{3})$', 'g')
const str = `A 123
B 323`;
const subst = `'C [a-z]*$1'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);