$re = '/(?m)^[AB][ ]([0-9]{3})$/';
$str = 'A 123
B 323';
$subst = "'C [a-z]*$1'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;