using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Employee:\s*(?P<employee>.+)[\n\r]
Department:\s*(?P<department>.+)";
string input = @"here might be some bla bla as well
Employee: Joe Banana
Department: Sales
Location: New York
Bla bla bla
Note:
even more bla";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}