re = /Employee:\s*(?P<employee>.+)[\n\r]
Department:\s*(?P<department>.+)/mx
str = 'here might be some bla bla as well
Employee: Joe Banana
Department: Sales
Location: New York
Bla bla bla
Note:
even more bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end