$re = '/Employee:\s*(?P<employee>.+)[\n\r]
Department:\s*(?P<department>.+)/mx';
$str = 'here might be some bla bla as well
Employee: Joe Banana
Department: Sales
Location: New York
Bla bla bla
Note:
even more bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);