const regex = /Employee:\s*(?P<employee>.+)[\n\r]
Department:\s*(?P<department>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Employee:\\s*(?P<employee>.+)[\\n\\r]
Department:\\s*(?P<department>.+)', 'gm')
const str = `here might be some bla bla as well
Employee: Joe Banana
Department: Sales
Location: New York
Bla bla bla
Note:
even more bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}