# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b|\s/\n/g;t' <<< "func add(Num x, Num y) = x+y;"