#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b|\s"
Local $sString = "func add(Num x, Num y) = x+y;"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)