using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b|\s";
string substitution = @"\n";
string input = @"func add(Num x, Num y) = x+y;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}