$re = '/\b|\s/';
$str = 'func add(Num x, Num y) = x+y;';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;