import Foundation
let pattern = #"\b|\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"func add(Num x, Num y) = x+y;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)