use strict;
my $str = 'func add(Num x, Num y) = x+y;';
my $regex = qr/\b|\s/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";