using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\w)\s(?=\w\b)";
string substitution = @"$1";
string input = @"Abc defg h i j k, l mn, o p qrst.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}