const regex = /(?<!\S)(\w)\s(?=\w\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(\\w)\\s(?=\\w\\b)', 'g')
const str = `Abc defg h i j k, l mn, o p qrst.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);