$re = '/(?<!\S)(\w)\s(?=\w\b)/';
$str = 'Abc defg h i j k, l mn, o p qrst.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;