use strict;
my $str = 'Abc defg h i j k, l mn, o p qrst.';
my $regex = qr/(?<!\S)(\w)\s(?=\w\b)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";