import re
regex = re.compile(r"(?<!\S)(\w)\s(?=\w\b)")
test_str = "Abc defg h i j k, l mn, o p qrst."
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)