# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:<br\s*\\/?>)+)|(?<!<br)\s+(?!\\/?>)/$1\n/g;t' <<< "<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style='color:#B22222;'>Blaabla8</span> Blaabla9"