using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:<br\s*\/?>)+)|(?<!<br)\s+(?!\/?>)";
string substitution = @"$1\n";
string input = @"<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style='color:#B22222;'>Blaabla8</span> Blaabla9";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}