use strict;
my $str = '<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style=\'color:#B22222;\'>Blaabla8</span> Blaabla9';
my $regex = qr/((?:<br\s*\/?>)+)|(?<!<br)\s+(?!\/?>)/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";