$re = '/((?:<br\s*\/?>)+)|(?<!<br)\s+(?!\/?>)/';
$str = '<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style=\'color:#B22222;\'>Blaabla8</span> Blaabla9';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;