#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$"
Local $sString = "623456789" & @CRLF & _
"623 45 67 89" & @CRLF & _
"623.45.67.89" & @CRLF & _
"623-45-67-89" & @CRLF & _
"1234" & @CRLF & _
"6341234311341324" & @CRLF & _
"3453459680934983"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")