import re
regex = re.compile(r"(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$", flags=re.MULTILINE)
test_str = ("623456789\n"
"623 45 67 89\n"
"623.45.67.89\n"
"623-45-67-89\n"
"1234\n"
"6341234311341324\n"
"3453459680934983")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")