re = /(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$/m
str = '623456789
623 45 67 89
623.45.67.89
623-45-67-89
1234
6341234311341324
3453459680934983'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end