using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$";
string input = @"623456789
623 45 67 89
623.45.67.89
623-45-67-89
1234
6341234311341324
3453459680934983";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}