package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$`)
var str = `623456789
623 45 67 89
623.45.67.89
623-45-67-89
1234
6341234311341324
3453459680934983`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}