const regex = /(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(6\\d{2}(?:(?:[ \\.\\-]?)\\d{2}){3})$', 'gm')
const str = `623456789
623 45 67 89
623.45.67.89
623-45-67-89
1234
6341234311341324
3453459680934983`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}