// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(6\d{2}(?:(?:[ \.\-]?)\d{2}){3})$").unwrap();
let string = "623456789
623 45 67 89
623.45.67.89
623-45-67-89
1234
6341234311341324
3453459680934983";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}