#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "video(([0-9]){9}?)\_(([0-9]){9}?)"
Local $sString = "https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")