$re = '/video(([0-9]){9}?)\_(([0-9]){9}?)/';
$str = 'https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);