// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"video(([0-9]){9}?)\_(([0-9]){9}?)").unwrap();
let string = "https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}