package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`video(([0-9]){9}?)\_(([0-9]){9}?)`)
var str = `https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}