using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"video(([0-9]){9}?)\_(([0-9]){9}?)";
string input = @"https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}