const regex = /video(([0-9]){9}?)\_(([0-9]){9}?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('video(([0-9]){9}?)\\_(([0-9]){9}?)', '')
const str = `https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}