package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$`)
var str = `John Adam Ben
Dog cat parrot
sandwich coffee Biscuit
feel the difference
JOHN ADAM BEN
DoG cat PaRRoT
SANDWICH cofee Biscuit
feeL the diFFerence`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}