const regex = /^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\b[a-z]*[A-Za-z][a-z]*\\b\\s*)+$', 'gm')
const str = `John Adam Ben
Dog cat parrot
sandwich coffee Biscuit
feel the difference
JOHN ADAM BEN
DoG cat PaRRoT
SANDWICH cofee Biscuit
feeL the diFFerence`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}