import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\b[a-z]*[A-Za-z][a-z]*\\b\\s*)+$";
final String string = "John Adam Ben\n"
+ "Dog cat parrot\n"
+ "sandwich coffee Biscuit\n"
+ "feel the difference\n\n"
+ "JOHN ADAM BEN\n"
+ "DoG cat PaRRoT\n"
+ "SANDWICH cofee Biscuit\n"
+ "feeL the diFFerence";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}