import re
regex = re.compile(r"^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$", flags=re.MULTILINE)
test_str = ("John Adam Ben\n"
"Dog cat parrot\n"
"sandwich coffee Biscuit\n"
"feel the difference\n\n"
"JOHN ADAM BEN\n"
"DoG cat PaRRoT\n"
"SANDWICH cofee Biscuit\n"
"feeL the diFFerence")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")