re = /^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$/m
str = 'John Adam Ben
Dog cat parrot
sandwich coffee Biscuit
feel the difference
JOHN ADAM BEN
DoG cat PaRRoT
SANDWICH cofee Biscuit
feeL the diFFerence'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end