package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)GB(\s?\d){9}`)
var str = `GB009000909
GB 009000909
GB00 9 00 0 909
GB00 9 000 9 09
GB0 0 9 0 0 0 9 0 9
GB00 90 00 909
GB009 000909
GB00900 090 9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}