import re
regex = re.compile(r"GB(\s?\d){9}", flags=re.MULTILINE)
test_str = ("GB009000909\n"
"GB 009000909\n"
"GB00 9 00 0 909\n"
"GB00 9 000 9 09\n"
"GB0 0 9 0 0 0 9 0 9\n"
"GB00 90 00 909\n"
"GB009 000909\n"
"GB00900 090 9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")