re = /GB(\s?\d){9}/m
str = 'GB009000909
GB 009000909
GB00 9 00 0 909
GB00 9 000 9 09
GB0 0 9 0 0 0 9 0 9
GB00 90 00 909
GB009 000909
GB00900 090 9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end