// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)GB(\s?\d){9}").unwrap();
let string = "GB009000909
GB 009000909
GB00 9 00 0 909
GB00 9 000 9 09
GB0 0 9 0 0 0 9 0 9
GB00 90 00 909
GB009 000909
GB00900 090 9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}