import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "GB(\\s?\\d){9}";
final String string = "GB009000909\n"
+ "GB 009000909\n"
+ "GB00 9 00 0 909\n"
+ "GB00 9 000 9 09\n"
+ "GB0 0 9 0 0 0 9 0 9\n"
+ "GB00 90 00 909\n"
+ "GB009 000909\n"
+ "GB00900 090 9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}