#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\b5\*14\b.*?\b(\d+\.\d+)"
Local $sString = "120.65UAH Produkti Kvartal" & @CRLF & _
"5*14 14:24" & @CRLF & _
"Bal. 16603.52UAH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")