import Foundation
let pattern = #"(?s)\b5\*14\b.*?\b(\d+\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}