$re = '/(?s)\b5\*14\b.*?\b(\d+\.\d+)/';
$str = '120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);