package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\b5\*14\b.*?\b(\d+\.\d+)`)
var str = `120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}