import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\b5\\*14\\b.*?\\b(\\d+\\.\\d+)";
final String string = "120.65UAH Produkti Kvartal\n"
+ "5*14 14:24\n"
+ "Bal. 16603.52UAH";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}