#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:.*?one.*?){1}.*?)one"
Local $sString = "one two three one one asdfasdf one asdfasdf sdf one" & @CRLF & _
""
Local $sSubst = "\1\(one\)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)